升级到Xcode6.4后插件失效解决办法

Author Avatar
新风作浪 7月 08, 2015
  • 在其它设备中阅读本文章

升级到Xcode 6.4 之后,插件失效不能使用,

1、首先要知道xcode的UUID,在终端下输入以下命令,会打开一个info.plist的文件,复制DVTPlugInCompatibilityUUID对应的值。

open /Applications/Xcode.app/Contents/Info.plist

2、然后替换掉下面命令最后面的“7FDF5C7A-131F-4ABB-9EDC-8C5F8F0B8A90”,在终端上执行下面的命令

find ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins -name Info.plist -maxdepth 3 | xargs -I{} defaults write {} DVTPlugInCompatibilityUUIDs -array-add 7FDF5C7A-131F-4ABB-9EDC-8C5F8F0B8A90

3、最后重启Xcode

参考链接:

1、http://joeshang.github.io/2015/04/10/fix-xcode-upgrade-plugin-invalid
2、http://segmentfault.com/a/1190000002591005